home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / gnome-base / gconf-2.12.1 / gconf-2.12.1.ebuild < prev    next >
Text File  |  2006-04-25  |  2KB  |  96 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.12.1.ebuild,v 1.9 2006/02/03 17:14:43 gmsoft Exp $
  4.  
  5. inherit gnome2
  6.  
  7. MY_PN=GConf
  8. MY_P=${MY_PN}-${PV}
  9. PVP=(${PV//[-\._]/ })
  10. S=${WORKDIR}/${MY_P}
  11.  
  12. DESCRIPTION="Gnome Configuration System and Daemon"
  13. HOMEPAGE="http://www.gnome.org/"
  14. SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
  15.  
  16. LICENSE="LGPL-2"
  17. SLOT="2"
  18. KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86"
  19. IUSE="doc"
  20.  
  21. RDEPEND=">=dev-libs/glib-2.7
  22.     >=gnome-base/orbit-2.4
  23.     >=dev-libs/libxml2-2
  24.     dev-libs/popt
  25.     >=x11-libs/gtk+-2"
  26.  
  27. DEPEND="${RDEPEND}
  28.     >=dev-util/pkgconfig-0.9
  29.     doc? ( >=dev-util/gtk-doc-1 )"
  30.  
  31. # FIXME : consider merging the tree (?)
  32.  
  33. DOCS="ABOUT-NLS AUTHORS ChangeLog NEWS README TODO"
  34. USE_DESTDIR="1"
  35. MAKEOPTS="${MAKEOPTS} -j1"
  36.  
  37.  
  38. pkg_setup() {
  39.     G2CONF="--enable-gtk"
  40.     kill_gconf
  41. }
  42.  
  43. src_install() {
  44.  
  45.     gnome2_src_install
  46.  
  47.     # hack hack
  48.     dodir /etc/gconf/gconf.xml.mandatory
  49.     dodir /etc/gconf/gconf.xml.defaults
  50.     touch ${D}/etc/gconf/gconf.xml.mandatory/.keep${SLOT}
  51.     touch ${D}/etc/gconf/gconf.xml.defaults/.keep${SLOT}
  52.  
  53.     dodir /etc/env.d
  54.     dodir /root/.gconfd
  55.  
  56. }
  57.  
  58. kill_gconf() {
  59.  
  60.     # this function will kill all running gconfd that could be causing troubles
  61.     if [ -x /usr/bin/gconftool ]
  62.     then
  63.         /usr/bin/gconftool --shutdown
  64.     fi
  65.     if [ -x /usr/bin/gconftool-1 ]
  66.     then
  67.         /usr/bin/gconftool-1 --shutdown
  68.     fi
  69.  
  70.     # and for gconf 2
  71.     if [ -x /usr/bin/gconftool-2 ]
  72.     then
  73.         /usr/bin/gconftool-2 --shutdown
  74.     fi
  75.     return 0
  76.  
  77. }
  78.  
  79. pkg_preinst() {
  80.  
  81.     kill_gconf
  82.  
  83.     echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > ${IMAGE}/etc/env.d/50gconf
  84.  
  85. }
  86.  
  87. pkg_postinst() {
  88.     kill_gconf
  89.  
  90.     #change the permissions to avoid some gconf bugs
  91.     einfo "changing permissions for gconf dirs"
  92.     find  /etc/gconf/ -type d -exec chmod ugo+rx "{}" \;
  93.     einfo "changing permissions for gconf files"
  94.     find  /etc/gconf/ -type f -exec chmod ugo+r "{}" \;
  95. }
  96.